成人国产在线小视频_日韩寡妇人妻调教在线播放_色成人www永久在线观看_2018国产精品久久_亚洲欧美高清在线30p_亚洲少妇综合一区_黄色在线播放国产_亚洲另类技巧小说校园_国产主播xx日韩_a级毛片在线免费

資訊專欄INFORMATION COLUMN

[HackerRank] Time Conversion

longmon / 2865人閱讀

Problem

Given a time in AM/PM format, convert it to military (24-hour) time.

Input Format

A single string containing a time in 12-hour clock format.

Output Format

Convert and print the given time in 24-hour format.

Sample Input

07:05:45PM

Sample Output

19:05:45

Solution

1. using char[]

import java.io.*;
import java.util.*;

public class Solution {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        String str = in.next();
        char[] ch = str.toCharArray();
        char[] res = Arrays.copyOfRange(ch, 0, 8);

        if(ch[8] == "A" && str.substring(0,2).equals("12")) {
            res[0] = "0";
            res[1] = "0";
        }
        else if(ch[8] =="P" && !str.substring(0,2).equals("12")) {
            String hour = "" + (Integer.parseInt(str.substring(0,2)) + 12);
            char[] h = hour.toCharArray();
            res[0] = h[0];
            res[1] = h[1];
        }
        System.out.println(res);
    }
}

2. using StringBuilder()

import java.io.*;
import java.util.*;

public class Solution {
    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        String str = in.next();
        char[] inChar = str.toCharArray();
        StringBuilder sb = new StringBuilder();

        if(str.charAt(8) == "A" && str.substring(0,2).equals("12")) {
            sb.append("00");
            sb.append(str.substring(2, 8));
        }
        else if(str.charAt(8) =="P" && !str.substring(0,2).equals("12")) {
            
            String s = "" + (Integer.parseInt(str.substring(0,2)) + 12);
            sb.append(s);
            sb.append(str.substring(2, 8));
        }
        else sb.append(str.substring(0, 8));
        System.out.println(sb.toString());
    }
}

文章版權(quán)歸作者所有,未經(jīng)允許請勿轉(zhuǎn)載,若此文章存在違規(guī)行為,您可以聯(lián)系管理員刪除。

轉(zhuǎn)載請注明本文地址:http://systransis.cn/yun/66014.html

相關(guān)文章

  • [HackerRank] Simple Array Sum | A Very Big Sum

    Simple Array Sum Problem Given an array of N integers, can you find the sum of its elements? Input Format The first line contains an integer, N, denoting the size of the array. The second line contain...

    harriszh 評論0 收藏0
  • [HackerRank] Diagonal Difference

    Problem Given a square matrix of size N x N, calculate the absolute difference between the sums of its diagonals. Input Format The first line contains a single integer, N. The next N lines denote the ...

    warmcheng 評論0 收藏0

發(fā)表評論

0條評論

最新活動
閱讀需要支付1元查看
<